2005-09-27

WTP 1.0M8 is out

I have tried to applied the method descibed in my previous post de WTP 1.0M8 without must success.
First problem: the builder org.eclipse.wst.common.modulecore.DependencyGraphBuilder and the nature org.eclipse.jst.j2ee.web.WebNature have disappeared. It seems to enough to remove them from .project file
Second problem: my webapps which where deploying seemlessly on WTP 0.7 with Tomcat 5.5 are running like dogs under 1.0M8. Each time I edit a jsp file, it quicks in the builder, and wtp needs to republish the entire webapp to the server, reloading the context in the process. This renders quick editing almost impossible. and I don't event speak about modifying a java class on the fly.
Third problem: saving a jsp or java file is now really slow (probably linked to pb#2)
May be I screwed up my server settings or my projects settings. but I tried a clean eclipse install, a clean server definition, a clean projects checkout, with the same result.
I tried a demo app LowAirFare which works very well and doesn't republish on jsp editing, but does republish on class editing.
I really like to understand why my webapp gets republished when I edit a JSP.
I guess I'll have to revert to 0.7 until those issues are worked out.

2 comments:

Neale said...

I've seen a similar problem in WTP 0.7. Eventually switched to using manual instead of automatic deploy (selected on modules page of server properties)

Anonymous said...

this is a known critical bug in M8:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=105190

use M7 or patch your M8 with the changes attached to the bug report, M8 is unusable...